summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit074af75668dd491042b07a26059927da38f13663 (patch)
tree58362fbaa56de52bda6c4aafc825d5bf5c40ec09 /target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
parent96fa58bafd6b311a9a3686b704bf8074905c4bea (diff)
downloadmaster-31e0f0ae-074af75668dd491042b07a26059927da38f13663.tar.gz
master-31e0f0ae-074af75668dd491042b07a26059927da38f13663.tar.bz2
master-31e0f0ae-074af75668dd491042b07a26059927da38f13663.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39789
Diffstat (limited to 'target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch b/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
new file mode 100644
index 0000000000..cc9a971573
--- /dev/null
+++ b/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
@@ -0,0 +1,23 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -58,6 +58,10 @@ config MTD_SPLIT_UIMAGE_FW
+ bool "uImage based firmware partition parser"
+ select MTD_SPLIT
+
++config MTD_SPLIT_LZMA_FW
++ bool "LZMA compressed kernel based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -10,6 +10,7 @@ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
+ mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
++mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o