summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit074af75668dd491042b07a26059927da38f13663 (patch)
tree58362fbaa56de52bda6c4aafc825d5bf5c40ec09 /target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
parent96fa58bafd6b311a9a3686b704bf8074905c4bea (diff)
downloadmaster-31e0f0ae-074af75668dd491042b07a26059927da38f13663.tar.gz
master-31e0f0ae-074af75668dd491042b07a26059927da38f13663.tar.bz2
master-31e0f0ae-074af75668dd491042b07a26059927da38f13663.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39789
Diffstat (limited to 'target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch b/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
new file mode 100644
index 0000000000..02697f64eb
--- /dev/null
+++ b/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
+ offset and size of the unused portion of a rootfs partition
+ containing a squashfs.
+
++comment "Firmware partition parsers"
++
++config MTD_SPLIT_UIMAGE_FW
++ bool "uImage based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o