summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/729-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit6bd1a3700191f14d64c417a1e443ec035a4efee7 (patch)
tree2c3d28386bbc47c37b708c0937962caae6a5ffa9 /target/linux/generic/patches-3.13/729-phy-rtl8367b.patch
parentc67ec51c85184c4fb3b6cf13f6ffc1e810ecdc6f (diff)
downloadmaster-31e0f0ae-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.gz
master-31e0f0ae-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.bz2
master-31e0f0ae-6bd1a3700191f14d64c417a1e443ec035a4efee7.zip
add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39348
Diffstat (limited to 'target/linux/generic/patches-3.13/729-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.13/729-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.13/729-phy-rtl8367b.patch
new file mode 100644
index 0000000000..d69fc89e47
--- /dev/null
+++ b/target/linux/generic/patches-3.13/729-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -262,6 +262,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o