summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 05:52:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 05:52:02 +0000
commit7f7e0a21b854b54945299e960543bdc37d032914 (patch)
tree1934d9d2013d782ffb99629e2ee2ca1ca985dc97 /target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch
parentf26bb532cf0d3e3664fbdaed87fd31466a9f9644 (diff)
downloadmaster-31e0f0ae-7f7e0a21b854b54945299e960543bdc37d032914.tar.gz
master-31e0f0ae-7f7e0a21b854b54945299e960543bdc37d032914.tar.bz2
master-31e0f0ae-7f7e0a21b854b54945299e960543bdc37d032914.zip
kernel: remove linux 3.13 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44804
Diffstat (limited to 'target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch')
-rw-r--r--target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch b/target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch
deleted file mode 100644
index 21c06fcd0f..0000000000
--- a/target/linux/generic/patches-3.13/230-openwrt_lzma_options.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -303,7 +303,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
-
- quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma -9 && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
-
- quiet_cmd_lzo = LZO $@
---- a/scripts/gen_initramfs_list.sh
-+++ b/scripts/gen_initramfs_list.sh
-@@ -226,7 +226,7 @@ cpio_list=
- output="/dev/stdout"
- output_file=""
- is_cpio_compressed=
--compr="gzip -n -9 -f"
-+compr="gzip -n -9 -f -"
-
- arg="$1"
- case "$arg" in
-@@ -242,13 +242,13 @@ case "$arg" in
- output=${cpio_list}
- echo "$output_file" | grep -q "\.gz$" \
- && [ -x "`which gzip 2> /dev/null`" ] \
-- && compr="gzip -n -9 -f"
-+ && compr="gzip -n -9 -f -"
- echo "$output_file" | grep -q "\.bz2$" \
- && [ -x "`which bzip2 2> /dev/null`" ] \
-- && compr="bzip2 -9 -f"
-+ && compr="bzip2 -9 -f -"
- echo "$output_file" | grep -q "\.lzma$" \
- && [ -x "`which lzma 2> /dev/null`" ] \
-- && compr="lzma -9 -f"
-+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
- echo "$output_file" | grep -q "\.xz$" \
- && [ -x "`which xz 2> /dev/null`" ] \
- && compr="xz --check=crc32 --lzma2=dict=1MiB"
-@@ -315,7 +315,7 @@ if [ ! -z ${output_file} ]; then
- if [ "${is_cpio_compressed}" = "compressed" ]; then
- cat ${cpio_tfile} > ${output_file}
- else
-- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
-+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
- || (rm -f ${output_file} ; false)
- fi
- [ -z ${cpio_file} ] && rm ${cpio_tfile}
---- a/lib/decompress.c
-+++ b/lib/decompress.c
-@@ -47,6 +47,7 @@ static const struct compress_format comp
- { {037, 0236}, "gzip", gunzip },
- { {0x42, 0x5a}, "bzip2", bunzip2 },
- { {0x5d, 0x00}, "lzma", unlzma },
-+ { {0x6d, 0x00}, "lzma-openwrt", unlzma },
- { {0xfd, 0x37}, "xz", unxz },
- { {0x89, 0x4c}, "lzo", unlzo },
- { {0x02, 0x21}, "lz4", unlz4 },