summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/730-phy_b53.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commite72c7e17a475c00134c56f4392578ddc16a47a2e (patch)
tree842835f958f9c9ed315cb853173d51e43f76bbf5 /target/linux/generic/patches-3.12/730-phy_b53.patch
parent4341ea40379ed24c103e37b75661c62bfc3270f6 (diff)
downloadmaster-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.gz
master-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.bz2
master-31e0f0ae-e72c7e17a475c00134c56f4392578ddc16a47a2e.zip
preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38528
Diffstat (limited to 'target/linux/generic/patches-3.12/730-phy_b53.patch')
-rw-r--r--target/linux/generic/patches-3.12/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/730-phy_b53.patch b/target/linux/generic/patches-3.12/730-phy_b53.patch
new file mode 100644
index 0000000000..31b7df7b0a
--- /dev/null
+++ b/target/linux/generic/patches-3.12/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -261,6 +261,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o