summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-07-31 21:33:58 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-07-31 21:33:58 +0000
commit2b329390408f11bf3b91e71afe4f28e704457e05 (patch)
tree8a31a0c05ec44ef4ac08315e4ac2d1ea59021b95 /target/linux/generic/patches-3.10
parent83c803086c686aa73663f6c6391a7c2c916d1dd1 (diff)
downloadmaster-31e0f0ae-2b329390408f11bf3b91e71afe4f28e704457e05.tar.gz
master-31e0f0ae-2b329390408f11bf3b91e71afe4f28e704457e05.tar.bz2
master-31e0f0ae-2b329390408f11bf3b91e71afe4f28e704457e05.zip
kernel: refresh patches
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 41909
Diffstat (limited to 'target/linux/generic/patches-3.10')
-rw-r--r--target/linux/generic/patches-3.10/070-net_bridge_backports.patch4
-rw-r--r--target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch2
-rw-r--r--target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch12
-rw-r--r--target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch2
4 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/generic/patches-3.10/070-net_bridge_backports.patch b/target/linux/generic/patches-3.10/070-net_bridge_backports.patch
index f303c3a094..6f7e141c5e 100644
--- a/target/linux/generic/patches-3.10/070-net_bridge_backports.patch
+++ b/target/linux/generic/patches-3.10/070-net_bridge_backports.patch
@@ -555,7 +555,7 @@ Date: Tue May 21 21:52:54 2013 +0000
}
#endif
-@@ -1473,8 +1569,14 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1473,8 +1569,14 @@ static int br_multicast_ipv6_rcv(struct
* - MLD has always Router Alert hop-by-hop option
* - But we do not support jumbrograms.
*/
@@ -918,7 +918,7 @@ Date: Tue May 21 21:52:54 2013 +0000
static ssize_t show_multicast_querier(struct device *d,
struct device_attribute *attr,
char *buf)
-@@ -734,6 +759,7 @@ static struct attribute *bridge_attrs[]
+@@ -734,6 +759,7 @@ static struct attribute *bridge_attrs[]
&dev_attr_multicast_router.attr,
&dev_attr_multicast_snooping.attr,
&dev_attr_multicast_querier.attr,
diff --git a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
index e38e001689..407c980e01 100644
--- a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
@@ -25,7 +25,7 @@
Ethernet bridge, which means that the different Ethernet segments it
--- a/net/ipv6/Makefile
+++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
diff --git a/target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch
index 9ee6b01df0..c461199602 100644
--- a/target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-3.10/645-bridge_multicast_to_unicast.patch
@@ -197,7 +197,7 @@
}
#endif
-@@ -1447,6 +1474,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1447,6 +1474,7 @@ static int br_multicast_ipv4_rcv(struct
struct net_bridge_port *port,
struct sk_buff *skb)
{
@@ -205,7 +205,7 @@
struct sk_buff *skb2 = skb;
const struct iphdr *iph;
struct igmphdr *ih;
-@@ -1522,7 +1550,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1522,7 +1550,7 @@ static int br_multicast_ipv4_rcv(struct
case IGMP_HOST_MEMBERSHIP_REPORT:
case IGMPV2_HOST_MEMBERSHIP_REPORT:
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -214,7 +214,7 @@
break;
case IGMPV3_HOST_MEMBERSHIP_REPORT:
err = br_ip4_multicast_igmp3_report(br, port, skb2);
-@@ -1531,7 +1559,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1531,7 +1559,7 @@ static int br_multicast_ipv4_rcv(struct
err = br_ip4_multicast_query(br, port, skb2);
break;
case IGMP_HOST_LEAVE_MESSAGE:
@@ -223,7 +223,7 @@
break;
}
-@@ -1548,6 +1576,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1548,6 +1576,7 @@ static int br_multicast_ipv6_rcv(struct
struct net_bridge_port *port,
struct sk_buff *skb)
{
@@ -231,7 +231,7 @@
struct sk_buff *skb2;
const struct ipv6hdr *ip6h;
u8 icmp6_type;
-@@ -1659,7 +1688,8 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1659,7 +1688,8 @@ static int br_multicast_ipv6_rcv(struct
}
mld = (struct mld_msg *)skb_transport_header(skb2);
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -241,7 +241,7 @@
break;
}
case ICMPV6_MLD2_REPORT:
-@@ -1676,7 +1706,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1676,7 +1706,7 @@ static int br_multicast_ipv6_rcv(struct
goto out;
}
mld = (struct mld_msg *)skb_transport_header(skb2);
diff --git a/target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch b/target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch
index e27d0a04d6..93ff7ba71d 100644
--- a/target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch
+++ b/target/linux/generic/patches-3.10/657-qdisc_reduce_truesize.patch
@@ -24,7 +24,7 @@ commont qdiscs.
}
--- a/net/sched/sch_fifo.c
+++ b/net/sched/sch_fifo.c
-@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
+@@ -29,17 +29,21 @@ static int bfifo_enqueue(struct sk_buff
static int pfifo_enqueue(struct sk_buff *skb, struct Qdisc *sch)
{