summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/729-phy-tantos.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commitc0435a971e9c21ebf694b221717e7a73f12662ec (patch)
tree6daa92bd257c9376af180e7bb3649dca91589812 /target/linux/generic/patches-3.10/729-phy-tantos.patch
parent87203c404996884334a9584fce0d8a251bf9fb43 (diff)
downloadmaster-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.gz
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.bz2
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36663
Diffstat (limited to 'target/linux/generic/patches-3.10/729-phy-tantos.patch')
-rw-r--r--target/linux/generic/patches-3.10/729-phy-tantos.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/729-phy-tantos.patch b/target/linux/generic/patches-3.10/729-phy-tantos.patch
new file mode 100644
index 0000000000..13e687b70f
--- /dev/null
+++ b/target/linux/generic/patches-3.10/729-phy-tantos.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -256,3 +256,8 @@ endif # PHYLIB
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
++ select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o