summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commitc0435a971e9c21ebf694b221717e7a73f12662ec (patch)
tree6daa92bd257c9376af180e7bb3649dca91589812 /target/linux/generic/patches-3.10/729-phy-rtl8367b.patch
parent87203c404996884334a9584fce0d8a251bf9fb43 (diff)
downloadmaster-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.gz
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.bz2
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36663
Diffstat (limited to 'target/linux/generic/patches-3.10/729-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.10/729-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch b/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch
new file mode 100644
index 0000000000..33d37fdb87
--- /dev/null
+++ b/target/linux/generic/patches-3.10/729-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -245,6 +245,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o