summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/728-phy-micrel.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commitc0435a971e9c21ebf694b221717e7a73f12662ec (patch)
tree6daa92bd257c9376af180e7bb3649dca91589812 /target/linux/generic/patches-3.10/728-phy-micrel.patch
parent87203c404996884334a9584fce0d8a251bf9fb43 (diff)
downloadmaster-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.gz
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.bz2
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36663
Diffstat (limited to 'target/linux/generic/patches-3.10/728-phy-micrel.patch')
-rw-r--r--target/linux/generic/patches-3.10/728-phy-micrel.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/728-phy-micrel.patch b/target/linux/generic/patches-3.10/728-phy-micrel.patch
new file mode 100644
index 0000000000..baf5a4a7fd
--- /dev/null
+++ b/target/linux/generic/patches-3.10/728-phy-micrel.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -144,6 +144,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o