summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-24 20:39:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-24 20:39:36 +0000
commit7004b796658fe274026925f96fd3a6711e8a3f5d (patch)
treef455fb3d2062fd4ca23142c39ca96ea5e2d407fb /target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
parent0aca075a9795780062a0b1821e799cd8b1cd5111 (diff)
downloadmaster-31e0f0ae-7004b796658fe274026925f96fd3a6711e8a3f5d.tar.gz
master-31e0f0ae-7004b796658fe274026925f96fd3a6711e8a3f5d.tar.bz2
master-31e0f0ae-7004b796658fe274026925f96fd3a6711e8a3f5d.zip
kernel: refresh generic 3.10 patches
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43050
Diffstat (limited to 'target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch')
-rw-r--r--target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
index 407c980e01..7bb0ee8d5f 100644
--- a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
@@ -25,7 +25,7 @@
Ethernet bridge, which means that the different Ethernet segments it
--- a/net/ipv6/Makefile
+++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
@@ -49,7 +49,7 @@
int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
unsigned char banned_flags)
-@@ -5173,6 +5172,9 @@ int __init addrconf_init(void)
+@@ -5183,6 +5182,9 @@ int __init addrconf_init(void)
ipv6_addr_label_rtnl_register();
@@ -59,7 +59,7 @@
return 0;
errout:
rtnl_af_unregister(&inet6_ops);
-@@ -5191,6 +5193,9 @@ void addrconf_cleanup(void)
+@@ -5201,6 +5203,9 @@ void addrconf_cleanup(void)
struct net_device *dev;
int i;