summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commitc0435a971e9c21ebf694b221717e7a73f12662ec (patch)
tree6daa92bd257c9376af180e7bb3649dca91589812 /target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch
parent87203c404996884334a9584fce0d8a251bf9fb43 (diff)
downloadmaster-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.gz
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.bz2
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36663
Diffstat (limited to 'target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch')
-rw-r--r--target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch b/target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch
new file mode 100644
index 0000000000..44c6b04fcf
--- /dev/null
+++ b/target/linux/generic/patches-3.10/302-mips_no_branch_likely.patch
@@ -0,0 +1,11 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -87,7 +87,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also. Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y += -msoft-float
+ LDFLAGS_vmlinux += -G 0 -static -n -nostdlib --gc-sections
+ KBUILD_AFLAGS_MODULE += -mlong-calls