summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commitc0435a971e9c21ebf694b221717e7a73f12662ec (patch)
tree6daa92bd257c9376af180e7bb3649dca91589812 /target/linux/generic/patches-3.10/259-regmap_dynamic.patch
parent87203c404996884334a9584fce0d8a251bf9fb43 (diff)
downloadmaster-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.gz
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.tar.bz2
master-31e0f0ae-c0435a971e9c21ebf694b221717e7a73f12662ec.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36663
Diffstat (limited to 'target/linux/generic/patches-3.10/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.10/259-regmap_dynamic.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/259-regmap_dynamic.patch b/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
new file mode 100644
index 0000000000..36e8b61c27
--- /dev/null
+++ b/target/linux/generic/patches-3.10/259-regmap_dynamic.patch
@@ -0,0 +1,72 @@
+--- a/drivers/base/regmap/Kconfig
++++ b/drivers/base/regmap/Kconfig
+@@ -3,20 +3,24 @@
+ # subsystems should select the appropriate symbols.
+
+ config REGMAP
+- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_MMIO || REGMAP_IRQ)
+ select LZO_COMPRESS
+ select LZO_DECOMPRESS
+ select IRQ_DOMAIN if REGMAP_IRQ
+- bool
++ tristate "Regmap"
+
+ config REGMAP_I2C
+- tristate
++ select REGMAP
++ tristate "Regmap I2C"
+
+ config REGMAP_SPI
+- tristate
++ select REGMAP
++ depends on SPI_MASTER
++ tristate "Regmap SPI"
+
+ config REGMAP_MMIO
++ select REGMAP
+ tristate
+
+ config REGMAP_IRQ
++ select REGMAP
+ bool
+--- a/include/linux/regmap.h
++++ b/include/linux/regmap.h
+@@ -45,7 +45,7 @@ struct reg_default {
+ unsigned int def;
+ };
+
+-#ifdef CONFIG_REGMAP
++#if IS_ENABLED(CONFIG_REGMAP)
+
+ enum regmap_endian {
+ /* Unspecified -> 0 -> Backwards compatible default */
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
+@@ -1,6 +1,8 @@
+-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++ifdef CONFIG_DEBUG_FS
++regmap-core-objs += regmap-debugfs.o
++endif
++obj-$(CONFIG_REGMAP) += regmap-core.o
+ obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
+ obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
+ obj-$(CONFIG_REGMAP_MMIO) += regmap-mmio.o
+--- a/drivers/base/regmap/regmap.c
++++ b/drivers/base/regmap/regmap.c
+@@ -13,6 +13,7 @@
+ #include <linux/device.h>
+ #include <linux/slab.h>
+ #include <linux/export.h>
++#include <linux/module.h>
+ #include <linux/mutex.h>
+ #include <linux/err.h>
+ #include <linux/rbtree.h>
+@@ -1815,3 +1816,5 @@ static int __init regmap_initcall(void)
+ return 0;
+ }
+ postcore_initcall(regmap_initcall);
++
++MODULE_LICENSE("GPL");