summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/833-gpio_buttons.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
commitcf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4 (patch)
treef0d9e62c746434dde7a45ed0debd3eb94b92dc65 /target/linux/generic/patches-3.1/833-gpio_buttons.patch
parenta5f2fd63598414246a497e08a4433a0116f2f606 (diff)
downloadmaster-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.gz
master-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.bz2
master-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.zip
linux: generic: add support for 3.1-rc1
SVN-Revision: 27940
Diffstat (limited to 'target/linux/generic/patches-3.1/833-gpio_buttons.patch')
-rw-r--r--target/linux/generic/patches-3.1/833-gpio_buttons.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/833-gpio_buttons.patch b/target/linux/generic/patches-3.1/833-gpio_buttons.patch
new file mode 100644
index 0000000000..51d7721eb5
--- /dev/null
+++ b/target/linux/generic/patches-3.1/833-gpio_buttons.patch
@@ -0,0 +1,30 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -527,4 +527,20 @@ config INPUT_XEN_KBDDEV_FRONTEND
+ To compile this driver as a module, choose M here: the
+ module will be called xen-kbdfront.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -49,3 +49,4 @@ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wist
+ obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
+ obj-$(CONFIG_INPUT_XEN_KBDDEV_FRONTEND) += xen-kbdfront.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o