summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
commitcf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4 (patch)
treef0d9e62c746434dde7a45ed0debd3eb94b92dc65 /target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch
parenta5f2fd63598414246a497e08a4433a0116f2f606 (diff)
downloadmaster-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.gz
master-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.bz2
master-31e0f0ae-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.zip
linux: generic: add support for 3.1-rc1
SVN-Revision: 27940
Diffstat (limited to 'target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch')
-rw-r--r--target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch b/target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch
new file mode 100644
index 0000000000..cf1c62a822
--- /dev/null
+++ b/target/linux/generic/patches-3.1/430-mtd_myloader_partition_parser.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -157,6 +157,22 @@ config MTD_AR7_PARTS
+ ---help---
+ TI AR7 partitioning support
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o