summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/833-gpio_buttons.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:31:01 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:31:01 +0000
commit235e3319876d5d1354e2774ec73495fdeb2616ec (patch)
treed776ac5daed14d9e6ee5562e979d388420e8ff08 /target/linux/generic/patches-3.0/833-gpio_buttons.patch
parent0db9c2bd7d3620ba18fa784bda702d971783b4f6 (diff)
downloadmaster-31e0f0ae-235e3319876d5d1354e2774ec73495fdeb2616ec.tar.gz
master-31e0f0ae-235e3319876d5d1354e2774ec73495fdeb2616ec.tar.bz2
master-31e0f0ae-235e3319876d5d1354e2774ec73495fdeb2616ec.zip
linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 27191
Diffstat (limited to 'target/linux/generic/patches-3.0/833-gpio_buttons.patch')
-rw-r--r--target/linux/generic/patches-3.0/833-gpio_buttons.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.0/833-gpio_buttons.patch b/target/linux/generic/patches-3.0/833-gpio_buttons.patch
new file mode 100644
index 0000000000..bd5219c1c8
--- /dev/null
+++ b/target/linux/generic/patches-3.0/833-gpio_buttons.patch
@@ -0,0 +1,31 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -478,4 +478,20 @@ config INPUT_XEN_KBDDEV_FRONTEND
+ To compile this driver as a module, choose M here: the
+ module will be called xen-kbdfront.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -45,4 +45,5 @@ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wist
+ obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
+ obj-$(CONFIG_INPUT_XEN_KBDDEV_FRONTEND) += xen-kbdfront.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
+