summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
commit3fa43f54a267f45e42be641945573450a0a419b8 (patch)
treeafa65eace467c96d7b49262ac89892f8d8f977b6 /target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
parent71d8c66250eef1806d680a27d175c61dd9971a5e (diff)
downloadmaster-31e0f0ae-3fa43f54a267f45e42be641945573450a0a419b8.tar.gz
master-31e0f0ae-3fa43f54a267f45e42be641945573450a0a419b8.tar.bz2
master-31e0f0ae-3fa43f54a267f45e42be641945573450a0a419b8.zip
kernel: reorganize 2.6.39 patches
SVN-Revision: 26691
Diffstat (limited to 'target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch b/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..2edc4f33cb
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -449,4 +449,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o