summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
commita2d17ea8cf06f36d67c0d8850e580ce21a6bb837 (patch)
tree15c9d10a1c3c5b8cc071618dcf5210a9beaeff37 /target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
parent55081c6a197789823d03f6c16a47312407c611da (diff)
downloadmaster-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.gz
master-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.bz2
master-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.zip
target/linux: add preliminary 2.6.37 kernel support
SVN-Revision: 23828
Diffstat (limited to 'target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch b/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
new file mode 100644
index 0000000000..fdfeb54335
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/691-phy_rtl8366.patch
@@ -0,0 +1,44 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -156,4 +156,29 @@ config MDIO_OCTEON
+
+ If in doubt, say Y.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GENERIC_GPIO
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++ bool "RTL8366 switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY || RTL8366RB_PHY
++ depends on DEBUG_FS
++ default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o