summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/620-phy_adm6996.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
commita2d17ea8cf06f36d67c0d8850e580ce21a6bb837 (patch)
tree15c9d10a1c3c5b8cc071618dcf5210a9beaeff37 /target/linux/generic/patches-2.6.37/620-phy_adm6996.patch
parent55081c6a197789823d03f6c16a47312407c611da (diff)
downloadmaster-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.gz
master-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.bz2
master-31e0f0ae-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.zip
target/linux: add preliminary 2.6.37 kernel support
SVN-Revision: 23828
Diffstat (limited to 'target/linux/generic/patches-2.6.37/620-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/620-phy_adm6996.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/620-phy_adm6996.patch b/target/linux/generic/patches-2.6.37/620-phy_adm6996.patch
new file mode 100644
index 0000000000..bd387d1bc7
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/620-phy_adm6996.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -92,6 +92,11 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o