summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
commit206e5f313e425c2b727b64a023a62c1f3de59b72 (patch)
treed7d49f33d5b291ac9f72b066866fdc293cf47dc7 /target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch
parent28d7de48b8c1150b5d72da89a9fb51f271843579 (diff)
downloadmaster-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.gz
master-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.bz2
master-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.zip
linux/generic: add kernel 2.6.36 preliminary support
SVN-Revision: 22832
Diffstat (limited to 'target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch b/target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch
new file mode 100644
index 0000000000..34ac10ed39
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/691-phy_rtl8366.patch
@@ -0,0 +1,44 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -157,4 +157,29 @@ config MDIO_OCTEON
+
+ If in doubt, say Y.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GENERIC_GPIO
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++ bool "RTL8366 switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY || RTL8366RB_PHY
++ depends on DEBUG_FS
++ default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o