summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
commit206e5f313e425c2b727b64a023a62c1f3de59b72 (patch)
treed7d49f33d5b291ac9f72b066866fdc293cf47dc7 /target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch
parent28d7de48b8c1150b5d72da89a9fb51f271843579 (diff)
downloadmaster-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.gz
master-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.tar.bz2
master-31e0f0ae-206e5f313e425c2b727b64a023a62c1f3de59b72.zip
linux/generic: add kernel 2.6.36 preliminary support
SVN-Revision: 22832
Diffstat (limited to 'target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..9630940bfe
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -371,4 +371,8 @@ endif # LEDS_TRIGGERS
+
+ endif # LEDS_CLASS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o