summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.30/620-phy_adm6996.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commitda1bb88a2b900f0392b731ec47c5e1bff956fd8f (patch)
tree597146471e3eeafb4ba55e802e80b896770808ff /target/linux/generic/patches-2.6.30/620-phy_adm6996.patch
parent6117c04c9416b295347fb45c37e430f01df1d0d9 (diff)
downloadmaster-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.gz
master-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.bz2
master-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.zip
rename target/linux/generic-2.6 to generic
SVN-Revision: 21952
Diffstat (limited to 'target/linux/generic/patches-2.6.30/620-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-2.6.30/620-phy_adm6996.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.30/620-phy_adm6996.patch b/target/linux/generic/patches-2.6.30/620-phy_adm6996.patch
new file mode 100644
index 0000000000..8f61d95c2d
--- /dev/null
+++ b/target/linux/generic/patches-2.6.30/620-phy_adm6996.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -82,6 +82,11 @@ config LSI_ET1011C_PHY
+ ---help---
+ Supports the LSI ET1011C PHY.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_SMSC_PHY) += smsc.o
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o