summaryrefslogtreecommitdiffstats
path: root/target/linux/generic/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:10 +0000
commit8353a3bd455f1ee5e0250d0a97b5d058f21316c7 (patch)
tree0f6af0613d9efdcdba6f5858be47464ec38d28da /target/linux/generic/image
parent703c41cf01f9ab00dc63d400bdfec45a7f4d4c6f (diff)
downloadmaster-31e0f0ae-8353a3bd455f1ee5e0250d0a97b5d058f21316c7.tar.gz
master-31e0f0ae-8353a3bd455f1ee5e0250d0a97b5d058f21316c7.tar.bz2
master-31e0f0ae-8353a3bd455f1ee5e0250d0a97b5d058f21316c7.zip
generic: relocate: make the cacheline size configurable
Different targets have different cache line sizes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45163
Diffstat (limited to 'target/linux/generic/image')
-rw-r--r--target/linux/generic/image/relocate/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/generic/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 500423b63b..5f6ebeb096 100644
--- a/target/linux/generic/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
@@ -22,6 +22,7 @@ BOARD :=
FLASH_OFFS :=
FLASH_MAX :=
PLATFORM :=
+CACHELINE_SIZE := 32
CC := $(CROSS_COMPILE)gcc
LD := $(CROSS_COMPILE)ld
@@ -36,7 +37,8 @@ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-common -ffreestanding -fhonour-copts \
-mabi=32 -march=mips32r2 \
-Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap \
- -DCONFIG_CACHELINE_SIZE=32 -DKERNEL_ADDR=$(KERNEL_ADDR)
+ -DCONFIG_CACHELINE_SIZE=$(CACHELINE_SIZE) \
+ -DKERNEL_ADDR=$(KERNEL_ADDR)
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__