summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-06-12 18:10:09 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-06-12 18:10:09 +0000
commit61ff8d986dbcb3385eeb85f78ed5fd97c7104f3a (patch)
treeb0989d148c5b45bdf01627408cd224bf5851d173 /target/linux/generic-2.6
parent5ec4eabfcb534df62171372f28f5cd0aea83dbb7 (diff)
downloadmaster-31e0f0ae-61ff8d986dbcb3385eeb85f78ed5fd97c7104f3a.tar.gz
master-31e0f0ae-61ff8d986dbcb3385eeb85f78ed5fd97c7104f3a.tar.bz2
master-31e0f0ae-61ff8d986dbcb3385eeb85f78ed5fd97c7104f3a.zip
refresh 2.6.34 patches
SVN-Revision: 21768
Diffstat (limited to 'target/linux/generic-2.6')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch8
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch6
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch6
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch2
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch2
11 files changed, 21 insertions, 21 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch b/target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch
index ca0c10b20d..83e24451c1 100644
--- a/target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/020-mips_multi_machine_support.patch
@@ -176,7 +176,7 @@
unsigned int vced_count, vcei_count;
-@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/*
* For the first processor also print the system type
*/
diff --git a/target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch b/target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch
index eab03db50d..4d1072cd4c 100644
--- a/target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/089-mtd-samsung-flash.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct
+@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct
cfi_fixup_major_minor(cfi, extp);
diff --git a/target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch b/target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch
index 8178a225ee..41c487b689 100644
--- a/target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/110-netfilter_match_speedup.patch
@@ -127,10 +127,11 @@
e = (struct ipt_entry *)(loc_cpu_entry + off);
if (copy_to_user(userptr + off
-@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_
+@@ -1000,6 +1040,14 @@ copy_entries_to_user(unsigned int total_
+ ret = -EFAULT;
goto free_counters;
}
-
++
+ flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
+ if (copy_to_user(userptr + off
+ + offsetof(struct ipt_entry, ip.flags),
@@ -138,7 +139,6 @@
+ ret = -EFAULT;
+ goto free_counters;
+ }
-+
+
for (i = sizeof(struct ipt_entry);
i < e->target_offset;
- i += m->u.match_size) {
diff --git a/target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch b/target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch
index 8a0507fa01..d595346874 100644
--- a/target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/150-netfilter_imq.patch
@@ -1183,7 +1183,7 @@
/* return EBUSY when somebody else is registered, return EEXIST if the
* same handler is registered, return 0 in case of success. */
int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const
+@@ -81,7 +101,7 @@ void nf_unregister_queue_handlers(const
}
EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
diff --git a/target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch b/target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
index c40da10d69..c334b17d08 100644
--- a/target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/511-yaffs-cvs-2009-04-24.patch
@@ -11038,14 +11038,14 @@
+ yaffs_UnpackTags2(tags, &pt);
+ }
+ }
-
-- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-- tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
+ if (localData)
+ yaffs_ReleaseTempBuffer(dev, data, __LINE__);
+- if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
+ if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+ tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
if (retval == 0)
return YAFFS_OK;
else
diff --git a/target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch b/target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch
index aac38ff2e7..8f939a5b7b 100644
--- a/target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/601-phy-add-aneg-done-function.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -393,9 +393,18 @@ struct phy_driver {
+@@ -379,9 +379,18 @@ struct phy_driver {
*/
int (*config_aneg)(struct phy_device *phydev);
@@ -21,7 +21,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -695,6 +695,9 @@ int genphy_update_link(struct phy_device
+@@ -698,6 +698,9 @@ int genphy_update_link(struct phy_device
{
int status;
@@ -33,7 +33,7 @@
--- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c
-@@ -107,6 +107,9 @@ static inline int phy_aneg_done(struct p
+@@ -106,6 +106,9 @@ static inline int phy_aneg_done(struct p
{
int retval;
diff --git a/target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch b/target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch
index 2bc9d6754d..c375a97292 100644
--- a/target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/680-phy_ar8216.patch
@@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -111,6 +111,10 @@ config IP175C_PHY
- tristate "Driver for IC+ IP175C/IP178C switches"
+@@ -111,6 +111,10 @@ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
select SWCONFIG
+config AR8216_PHY
@@ -15,7 +15,7 @@
+++ b/drivers/net/phy/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
- obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
diff --git a/target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch
index 9e86748a86..e97b84d48c 100644
--- a/target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/690-phy_rtl8306.patch
@@ -14,7 +14,7 @@
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
- obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
diff --git a/target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch b/target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch
index ec07636308..34ac10ed39 100644
--- a/target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/691-phy_rtl8366.patch
@@ -32,7 +32,7 @@
endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
diff --git a/target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch b/target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch
index d884348238..c34a7e2657 100644
--- a/target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/971-ocf_20100325.patch
@@ -24,7 +24,7 @@
* All of these routines try to estimate how many bits of randomness a
* particular randomness source. They do this by keeping track of the
* first and second order deltas of the event timings.
-@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
+@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
}
#endif
diff --git a/target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch b/target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch
index ce2c487bff..245cec18a9 100644
--- a/target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch
+++ b/target/linux/generic-2.6/patches-2.6.34/975-ssb_update.patch
@@ -40,7 +40,7 @@
/* Helper to extract some _offset, which is one of the SSB_SPROM_XXX defines. */
#define SPEX16(_outvar, _offset, _mask, _shift) \
out->_outvar = ((in[SPOFF(_offset)] & (_mask)) >> (_shift))
-@@ -254,7 +254,7 @@ static int sprom_do_read(struct ssb_bus
+@@ -254,7 +254,7 @@ static int sprom_do_read(struct ssb_bus
int i;
for (i = 0; i < bus->sprom_size; i++)