summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
commit4503e77b0d53f912cbf9b32a14df71f61a9b1609 (patch)
tree14fd49a64056b8b9c39a14b92e06242d7801bc45 /target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch
parenta2225b8b293cd71d420b96d46c88ad612f3637be (diff)
downloadmaster-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.gz
master-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.bz2
master-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.zip
generic-2.6: add kernel 2.6.35 preliminary support (patches)
SVN-Revision: 21696
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..76413e9cef
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.35/970-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -836,3 +836,6 @@ config CRYPTO_ANSI_CPRNG
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #