summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-07 05:56:49 +0000
commit4503e77b0d53f912cbf9b32a14df71f61a9b1609 (patch)
tree14fd49a64056b8b9c39a14b92e06242d7801bc45 /target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch
parenta2225b8b293cd71d420b96d46c88ad612f3637be (diff)
downloadmaster-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.gz
master-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.tar.bz2
master-31e0f0ae-4503e77b0d53f912cbf9b32a14df71f61a9b1609.zip
generic-2.6: add kernel 2.6.35 preliminary support (patches)
SVN-Revision: 21696
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch
new file mode 100644
index 0000000000..e38c31de40
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.35/410-gpio_buttons.patch
@@ -0,0 +1,31 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -340,4 +340,20 @@ config INPUT_PCAP
+ To compile this driver as a module, choose M here: the
+ module will be called pcap_keys.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -32,4 +32,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR) += winb
+ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
+ obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
+