summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commitd138f99bb2325af7821b5ea592bf7e5602ef228e (patch)
tree7f77c9b45c329c20826f8a1f1a2875132a56b307 /target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch
parentf086ba1d82562fd9f373a737b62353dfccaa7c75 (diff)
downloadmaster-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.gz
master-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.bz2
master-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.zip
generic-2.6: add 2.6.34 preliminary support (patches)
SVN-Revision: 20140
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch
new file mode 100644
index 0000000000..862868c8d1
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -102,6 +102,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP175C_PHY
++ tristate "Driver for IC+ IP175C/IP178C switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o