summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commitd138f99bb2325af7821b5ea592bf7e5602ef228e (patch)
tree7f77c9b45c329c20826f8a1f1a2875132a56b307 /target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch
parentf086ba1d82562fd9f373a737b62353dfccaa7c75 (diff)
downloadmaster-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.gz
master-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.bz2
master-31e0f0ae-d138f99bb2325af7821b5ea592bf7e5602ef228e.zip
generic-2.6: add 2.6.34 preliminary support (patches)
SVN-Revision: 20140
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch
new file mode 100644
index 0000000000..0b5174cbbd
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -529,7 +529,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -567,6 +567,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+