summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-02-24 13:39:02 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-02-24 13:39:02 +0000
commitf1509eaf8c7261033ec69fea337bf8015aca6f3f (patch)
treef8a7dd58d21d00a24414b583e6d02dc1039730e0 /target/linux/generic-2.6/patches-2.6.32
parent5bc415c2d650dbf21da567415cfc1d8f3477ec72 (diff)
downloadmaster-31e0f0ae-f1509eaf8c7261033ec69fea337bf8015aca6f3f.tar.gz
master-31e0f0ae-f1509eaf8c7261033ec69fea337bf8015aca6f3f.tar.bz2
master-31e0f0ae-f1509eaf8c7261033ec69fea337bf8015aca6f3f.zip
kernel: add driver for the RTL8366RB switch
Thanks to Andrew Tarabaras. SVN-Revision: 19837
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch13
1 files changed, 9 insertions, 4 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch b/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
index 2f6b3c49f7..db29760c5b 100644
--- a/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
+++ b/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -141,4 +141,25 @@ config MDIO_GPIO
+@@ -141,4 +141,29 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module
will be called mdio-gpio.
@@ -17,9 +17,13 @@
+ tristate "Driver for the Realtek RTL8366S switch"
+ select SWCONFIG
+
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366S switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY
++ bool "RTL8366 switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY || RTL8366RB_PHY
+ depends on DEBUG_FS
+ default n
+
@@ -28,12 +32,13 @@
endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,8 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o