summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:57 +0000
commit0849a208ceec8623774c48a652f9c99ce3a5e472 (patch)
tree39a1ffeb12c3f64fece42077e9bbdb5f0237802c /target/linux/generic-2.6/patches-2.6.32
parent2d305bdc2338b3295d6338a0215ce4cf7bb027f8 (diff)
downloadmaster-31e0f0ae-0849a208ceec8623774c48a652f9c99ce3a5e472.tar.gz
master-31e0f0ae-0849a208ceec8623774c48a652f9c99ce3a5e472.tar.bz2
master-31e0f0ae-0849a208ceec8623774c48a652f9c99ce3a5e472.zip
ar71xx: fix oprofile support
SVN-Revision: 20150
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch
new file mode 100644
index 0000000000..2e019dba2c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/208-mips_oprofile_fix.patch
@@ -0,0 +1,47 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -48,7 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
+ endif
+ endif
+
++ifndef CONFIG_PROFILING
+ cflags-y := -ffunction-sections
++endif
+ cflags-y += $(call cc-option, -mno-check-zero-division)
+
+ ifdef CONFIG_32BIT
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+ }
+ }
+
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++ return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+ int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+ save_perf_irq = perf_irq;
+ perf_irq = mipsxx_perfcount_handler;
+
++ if (cp0_perfcount_irq >= 0)
++ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++ IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+ return 0;
+ }
+
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+ int counters = op_model_mipsxx_ops.num_counters;
+
++ if (cp0_perfcount_irq >= 0)
++ free_irq(cp0_perfcount_irq, save_perf_irq);
++
+ counters = counters_per_cpu_to_total(counters);
+ on_each_cpu(reset_counters, (void *)(long)counters, 1);
+