summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commitda1bb88a2b900f0392b731ec47c5e1bff956fd8f (patch)
tree597146471e3eeafb4ba55e802e80b896770808ff /target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
parent6117c04c9416b295347fb45c37e430f01df1d0d9 (diff)
downloadmaster-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.gz
master-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.bz2
master-31e0f0ae-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.zip
rename target/linux/generic-2.6 to generic
SVN-Revision: 21952
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch b/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
deleted file mode 100644
index 56050912c1..0000000000
--- a/target/linux/generic-2.6/patches-2.6.32/691-phy_rtl8366.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -141,4 +141,29 @@ config MDIO_GPIO
- To compile this driver as a module, choose M here: the module
- will be called mdio-gpio.
-
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GENERIC_GPIO
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366RB_PHY
-+ tristate "Driver for the Realtek RTL8366RB switch"
-+ select SWCONFIG
-+
-+config RTL8366S_PHY_DEBUG_FS
-+ bool "RTL8366 switch driver DEBUG_FS support"
-+ depends on RTL8366S_PHY || RTL8366RB_PHY
-+ depends on DEBUG_FS
-+ default n
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o