summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
commit3d4466cfd8f75f717efdb1f96fdde3c70d865fc1 (patch)
treee0d2b76bad5b0289f4a3ab013ad698dcc284e1c5 /target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch
parentab81d139c7675244c704ef5cad4407dbbae8c351 (diff)
downloadmaster-31e0f0ae-3d4466cfd8f75f717efdb1f96fdde3c70d865fc1.tar.gz
master-31e0f0ae-3d4466cfd8f75f717efdb1f96fdde3c70d865fc1.tar.bz2
master-31e0f0ae-3d4466cfd8f75f717efdb1f96fdde3c70d865fc1.zip
add preliminary 2.6.32 support
SVN-Revision: 18283
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..a4793cb63b
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -110,6 +110,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o