summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-29 13:02:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-29 13:02:41 +0000
commita523450678c76495e002fb8df8d049f36e1e4b42 (patch)
treeeb61125cf940b684b3a7c2856ab40cbcc0481326 /target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
parentd26ec37d18b7d14a1a0f52bee8b3be35058bdd46 (diff)
downloadmaster-31e0f0ae-a523450678c76495e002fb8df8d049f36e1e4b42.tar.gz
master-31e0f0ae-a523450678c76495e002fb8df8d049f36e1e4b42.tar.bz2
master-31e0f0ae-a523450678c76495e002fb8df8d049f36e1e4b42.zip
Add a driver for Atheros AR8216 switches Thanks to Vertical Communications, Inc. for providing access to the documentation
SVN-Revision: 15482
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch b/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
new file mode 100644
index 0000000000..2e9bab10e3
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -84,6 +84,10 @@ config IP175C_PHY
+ tristate "Driver for IC+ IP175C/IP178C switches"
+ select SWCONFIG
+
++config AR8216_PHY
++ tristate "Driver for Atheros AR8216 switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o