summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
commit2d0ccf7f5e0d98cb621550f88f19f7380fc06728 (patch)
tree9b1bdaac0af6496bf8da5f128461aeb79cd778c8 /target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch
parentf87df4b3615bc4e0bd9e19671f942f23782fb2ff (diff)
downloadmaster-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.gz
master-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.bz2
master-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.zip
preliminary 2.6.30 support
SVN-Revision: 15468
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch b/target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch
new file mode 100644
index 0000000000..731f30301f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/660-phy_mvswitch.patch
@@ -0,0 +1,22 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -93,6 +93,9 @@ config ADM6996_PHY
+ ---help---
+ Currently supports the ADM6996F switch
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell 88E6060 switches"
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -14,6 +14,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o