summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-29 20:46:49 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-29 20:46:49 +0000
commita528df4bb62b5f6b559e1f78483cd8cbd3eb8cd9 (patch)
tree3dfbc8c879143de9b7692bc6e527ea0c499e362e /target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
parentfab598b67528b7ba8867b12037f738696a30f9c9 (diff)
downloadmaster-31e0f0ae-a528df4bb62b5f6b559e1f78483cd8cbd3eb8cd9.tar.gz
master-31e0f0ae-a528df4bb62b5f6b559e1f78483cd8cbd3eb8cd9.tar.bz2
master-31e0f0ae-a528df4bb62b5f6b559e1f78483cd8cbd3eb8cd9.zip
resync patches for 2.6.30-rc3
SVN-Revision: 15494
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
index 6077906ae3..139d997dfb 100644
--- a/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
+++ b/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
@@ -1,8 +1,8 @@
--- a/drivers/input/misc/Kconfig
+++ b/drivers/input/misc/Kconfig
-@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
- Say Y to include support for delivering PMU events via input
- layer on NXP PCF50633.
+@@ -250,4 +250,20 @@ config INPUT_RB532_BUTTON
+ To compile this driver as a module, choose M here: the
+ module will be called rb532_button.
+config INPUT_GPIO_BUTTONS
+ tristate "Polled GPIO buttons interface"
@@ -23,8 +23,8 @@
endif
--- a/drivers/input/misc/Makefile
+++ b/drivers/input/misc/Makefile
-@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
- obj-$(CONFIG_INPUT_APANEL) += apanel.o
- obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
- obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
+@@ -24,3 +24,4 @@ obj-$(CONFIG_INPUT_SPARCSPKR) += sparcs
+ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o