summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
commit2d0ccf7f5e0d98cb621550f88f19f7380fc06728 (patch)
tree9b1bdaac0af6496bf8da5f128461aeb79cd778c8 /target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
parentf87df4b3615bc4e0bd9e19671f942f23782fb2ff (diff)
downloadmaster-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.gz
master-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.tar.bz2
master-31e0f0ae-2d0ccf7f5e0d98cb621550f88f19f7380fc06728.zip
preliminary 2.6.30 support
SVN-Revision: 15468
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
new file mode 100644
index 0000000000..91dd68b914
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -561,6 +561,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+