summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:04:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:04:16 +0000
commitbe37a62e6d6e328c936beadd12a8059764fa6e12 (patch)
treecde758e42a625ac3fbcd4004200df28f03d2c8e2 /target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
parent05d8459bb9f96b9e0a19b8735d3bee05484eca22 (diff)
downloadmaster-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.tar.gz
master-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.tar.bz2
master-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.zip
add generic 2.6.29 patches and config (squashfs still untested, user space mkfs still missing)
SVN-Revision: 15251
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..e994ff713c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -734,6 +734,8 @@ config CRYPTO_ANSI_CPRNG
+ for cryptographic modules. Uses the Algorithm specified in
+ ANSI X9.31 A.2.4
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -80,6 +80,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o