summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:04:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:04:16 +0000
commitbe37a62e6d6e328c936beadd12a8059764fa6e12 (patch)
treecde758e42a625ac3fbcd4004200df28f03d2c8e2 /target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch
parent05d8459bb9f96b9e0a19b8735d3bee05484eca22 (diff)
downloadmaster-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.tar.gz
master-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.tar.bz2
master-31e0f0ae-be37a62e6d6e328c936beadd12a8059764fa6e12.zip
add generic 2.6.29 patches and config (squashfs still untested, user space mkfs still missing)
SVN-Revision: 15251
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch
new file mode 100644
index 0000000000..989e253d7c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1016,6 +1016,13 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -94,6 +94,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o