summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-28 10:00:48 +0000
commit7adb67f18469e51cecb83a0c2efbf22494acb244 (patch)
treefe225b163b00d82bf2dfa88ec105309675690049 /target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
parent52d975c359b8330e2844d3bb942588bd5afd73e6 (diff)
downloadmaster-31e0f0ae-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.gz
master-31e0f0ae-7adb67f18469e51cecb83a0c2efbf22494acb244.tar.bz2
master-31e0f0ae-7adb67f18469e51cecb83a0c2efbf22494acb244.zip
revert 15922 - add back 2.6.29 kernel support
SVN-Revision: 16127
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
new file mode 100644
index 0000000000..6077906ae3
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.29/410-gpio_buttons.patch
@@ -0,0 +1,30 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
+ Say Y to include support for delivering PMU events via input
+ layer on NXP PCF50633.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_APANEL) += apanel.o
+ obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
+ obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o