summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-14 00:52:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-14 00:52:17 +0000
commit6e28b28c5e8a3b84d0e36905c78e95e2a8576ff8 (patch)
tree315d74d1626c1696e20f8f0b69d5226b48688353 /target/linux/generic-2.6/patches-2.6.28
parentfe8feb1eaad3fa1568c177d02a7c26fffb417ddd (diff)
downloadmaster-31e0f0ae-6e28b28c5e8a3b84d0e36905c78e95e2a8576ff8.tar.gz
master-31e0f0ae-6e28b28c5e8a3b84d0e36905c78e95e2a8576ff8.tar.bz2
master-31e0f0ae-6e28b28c5e8a3b84d0e36905c78e95e2a8576ff8.zip
add a driver for rtl8306 switches
SVN-Revision: 17248
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..e88db16649
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -88,6 +88,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o