summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-09-16 12:24:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-09-16 12:24:46 +0000
commit30e635c55b834c4b75cd98b3e39d24df1a900913 (patch)
treed0861b606a1988e26eddc1c9a74c8ee14ce78ac7 /target/linux/generic-2.6/patches-2.6.28
parent8bf5ee0324976c1665c626e75d419bd300d7b42e (diff)
downloadmaster-31e0f0ae-30e635c55b834c4b75cd98b3e39d24df1a900913.tar.gz
master-31e0f0ae-30e635c55b834c4b75cd98b3e39d24df1a900913.tar.bz2
master-31e0f0ae-30e635c55b834c4b75cd98b3e39d24df1a900913.zip
move the updated version (for 2.6.30+) of ar8216/mvswitch to the generic files directory and remove patches for older kernel versions (no longer in use)
SVN-Revision: 17594
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch22
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/670-phy_ip175c.patch10
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/680-phy_ar8216.patch23
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch10
4 files changed, 10 insertions, 55 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch b/target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch
deleted file mode 100644
index 29b9c31f05..0000000000
--- a/target/linux/generic-2.6/patches-2.6.28/660-phy_mvswitch.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -77,6 +77,9 @@ config ADM6996_PHY
- ---help---
- Currently supports the ADM6996F switch
-
-+config MVSWITCH_PHY
-+ tristate "Driver for Marvell 88E6060 switches"
-+
- config FIXED_PHY
- bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
- depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -14,6 +14,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
- obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
- obj-$(CONFIG_ICPLUS_PHY) += icplus.o
- obj-$(CONFIG_ADM6996_PHY) += adm6996.o
-+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic-2.6/patches-2.6.28/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.28/670-phy_ip175c.patch
index 380d18d4e4..02a5947aa4 100644
--- a/target/linux/generic-2.6/patches-2.6.28/670-phy_ip175c.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/670-phy_ip175c.patch
@@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -80,6 +80,10 @@ config ADM6996_PHY
- config MVSWITCH_PHY
- tristate "Driver for Marvell 88E6060 switches"
+@@ -77,6 +77,10 @@ config ADM6996_PHY
+ ---help---
+ Currently supports the ADM6996F switch
+config IP175C_PHY
+ tristate "Driver for IC+ IP175C/IP178C switches"
@@ -13,10 +13,10 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+@@ -14,6 +14,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/generic-2.6/patches-2.6.28/680-phy_ar8216.patch b/target/linux/generic-2.6/patches-2.6.28/680-phy_ar8216.patch
deleted file mode 100644
index 2e9bab10e3..0000000000
--- a/target/linux/generic-2.6/patches-2.6.28/680-phy_ar8216.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -84,6 +84,10 @@ config IP175C_PHY
- tristate "Driver for IC+ IP175C/IP178C switches"
- select SWCONFIG
-
-+config AR8216_PHY
-+ tristate "Driver for Atheros AR8216 switches"
-+ select SWCONFIG
-+
- config FIXED_PHY
- bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
- depends on PHYLIB=y
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
- obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
- obj-$(CONFIG_IP175C_PHY) += ip175c.o
-+obj-$(CONFIG_AR8216_PHY) += ar8216.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch
index e88db16649..b56d55b459 100644
--- a/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/690-phy_rtl8306.patch
@@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -88,6 +88,10 @@ config AR8216_PHY
- tristate "Driver for Atheros AR8216 switches"
+@@ -81,6 +81,10 @@ config IP175C_PHY
+ tristate "Driver for IC+ IP175C/IP178C switches"
select SWCONFIG
+config RTL8306_PHY
@@ -13,10 +13,10 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_FIXED_PHY) += fixed.o