summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commitf21f51d858ab97a4784f76481c336613abc127f6 (patch)
treee1d1a3380f15b3a411c3eeffb9adea9f6f82628b /target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
parent206ccdf4ae2f236a752950a701bb3eacbdaf2cc8 (diff)
downloadmaster-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.gz
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.bz2
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.zip
add generic 2.6.28 patches
SVN-Revision: 13546
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
new file mode 100644
index 0000000000..c7b665a67a
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/420-gpiodev.patch
@@ -0,0 +1,26 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -988,6 +988,13 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
+ config GPIO_VR41XX
+ tristate "NEC VR4100 series General-purpose I/O Unit support"
+ depends on CPU_VR41XX
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -92,6 +92,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o