summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commitf21f51d858ab97a4784f76481c336613abc127f6 (patch)
treee1d1a3380f15b3a411c3eeffb9adea9f6f82628b /target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch
parent206ccdf4ae2f236a752950a701bb3eacbdaf2cc8 (diff)
downloadmaster-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.gz
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.tar.bz2
master-31e0f0ae-f21f51d858ab97a4784f76481c336613abc127f6.zip
add generic 2.6.28 patches
SVN-Revision: 13546
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..8d3dd8e6d3
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -217,4 +217,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ This allows LEDs to be initialised in the ON state.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -30,3 +30,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o