summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-29 01:08:17 +0000
commitbc92b67c41bb9eb64dd342735cf04d0ca5098926 (patch)
treefb3cad267265be9ac8eb1532182422f278dc3d0a /target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch
parent9b2097af21c4298fb67622266d5587e4e680fc5c (diff)
downloadmaster-31e0f0ae-bc92b67c41bb9eb64dd342735cf04d0ca5098926.tar.gz
master-31e0f0ae-bc92b67c41bb9eb64dd342735cf04d0ca5098926.tar.bz2
master-31e0f0ae-bc92b67c41bb9eb64dd342735cf04d0ca5098926.zip
port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but otherwise completely untested)
SVN-Revision: 12790
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..01e27573bc
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.27/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,19 @@
+--- a/fs/squashfs/Makefile
++++ b/fs/squashfs/Makefile
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+--- a/fs/squashfs/squashfs.h
++++ b/fs/squashfs/squashfs.h
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)