summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-10-15 19:30:21 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-10-15 19:30:21 +0000
commit19b0e56ba7d5a1c93075cac3d662486917a9ef35 (patch)
tree030ca3ec5a74f7bf1a96580ad73d6e22956198b1 /target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch
parent3b90e01db8852a89a0925e0b44faec6119d6c5c9 (diff)
downloadmaster-31e0f0ae-19b0e56ba7d5a1c93075cac3d662486917a9ef35.tar.gz
master-31e0f0ae-19b0e56ba7d5a1c93075cac3d662486917a9ef35.tar.bz2
master-31e0f0ae-19b0e56ba7d5a1c93075cac3d662486917a9ef35.zip
refresh patches against 2.6.27 final
SVN-Revision: 12987
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch b/target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch
index 97ba7635ca..b8176914c1 100644
--- a/target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch
+++ b/target/linux/generic-2.6/patches-2.6.27/001-squashfs.patch
@@ -1,6 +1,6 @@
--- a/fs/Kconfig
+++ b/fs/Kconfig
-@@ -1348,6 +1348,71 @@
+@@ -1348,6 +1348,71 @@ config CRAMFS
If unsure, say N.
@@ -74,7 +74,7 @@
depends on BLOCK
--- a/fs/Makefile
+++ b/fs/Makefile
-@@ -74,6 +74,7 @@
+@@ -74,6 +74,7 @@ obj-$(CONFIG_JBD) += jbd/
obj-$(CONFIG_JBD2) += jbd2/
obj-$(CONFIG_EXT2_FS) += ext2/
obj-$(CONFIG_CRAMFS) += cramfs/
@@ -4128,7 +4128,7 @@
#include <linux/initrd.h>
#include <linux/string.h>
-@@ -37,6 +38,7 @@
+@@ -37,6 +38,7 @@ static int __init crd_load(int in_fd, in
* numbers could not be found.
*
* We currently check for the following magic numbers:
@@ -4136,7 +4136,7 @@
* minix
* ext2
* romfs
-@@ -51,6 +53,7 @@
+@@ -51,6 +53,7 @@ identify_ramdisk_image(int fd, int start
struct ext2_super_block *ext2sb;
struct romfs_super_block *romfsb;
struct cramfs_super *cramfsb;
@@ -4144,7 +4144,7 @@
int nblocks = -1;
unsigned char *buf;
-@@ -62,6 +65,7 @@
+@@ -62,6 +65,7 @@ identify_ramdisk_image(int fd, int start
ext2sb = (struct ext2_super_block *) buf;
romfsb = (struct romfs_super_block *) buf;
cramfsb = (struct cramfs_super *) buf;
@@ -4152,7 +4152,7 @@
memset(buf, 0xe5, size);
/*
-@@ -99,6 +103,15 @@
+@@ -99,6 +103,15 @@ identify_ramdisk_image(int fd, int start
goto done;
}