summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-19 20:32:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-19 20:32:13 +0000
commit88dd88931466259ca3b785de42f8088274348081 (patch)
treeb479e95e84062d086e9f31fc0d6c4f357deb402f /target/linux/generic-2.6/patches-2.6.26
parenta81c3dacb9430df85c4b5e519ded9f1a9d8dd341 (diff)
downloadmaster-31e0f0ae-88dd88931466259ca3b785de42f8088274348081.tar.gz
master-31e0f0ae-88dd88931466259ca3b785de42f8088274348081.tar.bz2
master-31e0f0ae-88dd88931466259ca3b785de42f8088274348081.zip
restore accidentally deleted ofc patches
SVN-Revision: 13293
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..3057307f27
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -675,6 +675,8 @@ config CRYPTO_PRNG
+ for cryptographic modules. Uses the Algorithm specified in
+ ANSI X9.31 A.2.4
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -73,6 +73,11 @@ obj-$(CONFIG_CRYPTO_PRNG) += prng.o
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o