summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-10-18 20:44:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-10-18 20:44:53 +0000
commit487c622ac0c37f3cd26add56df9081ea7caf3835 (patch)
tree93a3d22cf39a79edfcdadb213520d920c871fdd1 /target/linux/generic-2.6/patches-2.6.26
parentfa6b45287347380c8aa1630930fdd47edb11cd86 (diff)
downloadmaster-31e0f0ae-487c622ac0c37f3cd26add56df9081ea7caf3835.tar.gz
master-31e0f0ae-487c622ac0c37f3cd26add56df9081ea7caf3835.tar.bz2
master-31e0f0ae-487c622ac0c37f3cd26add56df9081ea7caf3835.zip
add new switch configuration api
SVN-Revision: 13009
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/650-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/650-swconfig.patch b/target/linux/generic-2.6/patches-2.6.26/650-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/650-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o