summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.26
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-17 10:14:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-17 10:14:58 +0000
commit442db57b96dcf2bcaa8ace560d83d4c045d97a26 (patch)
tree85fd9cf0e91e27c8273d041302cdf3c8bf5ebb01 /target/linux/generic-2.6/patches-2.6.26
parent2aaf71e42f0a08b5c0056a09a3f5df5ddb2c830a (diff)
downloadmaster-31e0f0ae-442db57b96dcf2bcaa8ace560d83d4c045d97a26.tar.gz
master-31e0f0ae-442db57b96dcf2bcaa8ace560d83d4c045d97a26.tar.bz2
master-31e0f0ae-442db57b96dcf2bcaa8ace560d83d4c045d97a26.zip
move MyLoader partition parser into generic files, will be used on ar71xx
SVN-Revision: 13256
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.26')
-rw-r--r--target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch b/target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch
new file mode 100644
index 0000000000..17cd986aee
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.26/081-mtd_myloader_partition_parser.patch
@@ -0,0 +1,35 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -174,6 +174,22 @@ config MTD_AR7_PARTS
+ ---help---
+ TI AR7 partitioning support
+
++config MTD_MYLOADER_PARTS
++ tristate "MyLoader partition parsing"
++ depends on ADM5120 && MTD_PARTITIONS
++ ---help---
++ MyLoader is a bootloader which allows the user to define partitions
++ in flash devices, by putting a table in the second erase block
++ on the device, similar to a partition table. This table gives the
++ offsets and lengths of the user defined partitions.
++
++ If you need code which can detect and parse these tables, and
++ register MTD 'partitions' corresponding to each image detected,
++ enable this option.
++
++ You will still need the parsing functions to be called by the driver
++ for your particular device. It won't happen automatically.
++
+ comment "User Modules And Translation Layers"
+
+ config MTD_CHAR
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
++obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+
+ # 'Users' - code which presents functionality to userspace.
+ obj-$(CONFIG_MTD_CHAR) += mtdchar.o