summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25
diff options
context:
space:
mode:
authorMatteo Croce <rootkit85@yahoo.it>2008-05-13 00:10:45 +0000
committerMatteo Croce <rootkit85@yahoo.it>2008-05-13 00:10:45 +0000
commit2058b8096491f4976710ecbd1d70d82c4ffaae13 (patch)
tree44147cf5f33a794e33e03536210590522f61b077 /target/linux/generic-2.6/patches-2.6.25
parent06c7c0428831969f02dcb5585edb859cf7025640 (diff)
downloadmaster-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.tar.gz
master-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.tar.bz2
master-31e0f0ae-2058b8096491f4976710ecbd1d70d82c4ffaae13.zip
atheros: added marvell switch driver
SVN-Revision: 11129
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/610-phy_detect.patch30
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/620-phy_adm6996.patch28
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/630-phy_packets.patch66
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch54
4 files changed, 178 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/610-phy_detect.patch b/target/linux/generic-2.6/patches-2.6.25/610-phy_detect.patch
new file mode 100644
index 0000000000..454415341f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/610-phy_detect.patch
@@ -0,0 +1,30 @@
+Index: linux-2.6.25.1/drivers/net/phy/mdio_bus.c
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/mdio_bus.c 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/mdio_bus.c 2008-05-12 23:44:21.000000000 +0200
+@@ -132,6 +132,9 @@
+ struct phy_device *phydev = to_phy_device(dev);
+ struct phy_driver *phydrv = to_phy_driver(drv);
+
++ if (phydrv->detect)
++ return (phydrv->detect(phydev->bus, phydev->addr));
++
+ return ((phydrv->phy_id & phydrv->phy_id_mask) ==
+ (phydev->phy_id & phydrv->phy_id_mask));
+ }
+Index: linux-2.6.25.1/include/linux/phy.h
+===================================================================
+--- linux-2.6.25.1.orig/include/linux/phy.h 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/include/linux/phy.h 2008-05-12 23:44:21.000000000 +0200
+@@ -325,6 +325,11 @@
+ u32 features;
+ u32 flags;
+
++ /* Called during discovery to test if the
++ * device can attach to the bus, even if
++ * phy id and mask do not match */
++ bool (*detect)(struct mii_bus *bus, int addr);
++
+ /* Called to initialize the PHY,
+ * including after a reset */
+ int (*config_init)(struct phy_device *phydev);
diff --git a/target/linux/generic-2.6/patches-2.6.25/620-phy_adm6996.patch b/target/linux/generic-2.6/patches-2.6.25/620-phy_adm6996.patch
new file mode 100644
index 0000000000..10da7cf7ff
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/620-phy_adm6996.patch
@@ -0,0 +1,28 @@
+Index: linux-2.6.25.1/drivers/net/phy/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Kconfig 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Kconfig 2008-05-12 23:44:33.000000000 +0200
+@@ -65,6 +65,11 @@
+ ---help---
+ Supports the Realtek 821x PHY.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+Index: linux-2.6.25.1/drivers/net/phy/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Makefile 2008-05-01 23:45:25.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Makefile 2008-05-12 23:44:50.000000000 +0200
+@@ -12,6 +12,7 @@
+ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic-2.6/patches-2.6.25/630-phy_packets.patch b/target/linux/generic-2.6/patches-2.6.25/630-phy_packets.patch
new file mode 100644
index 0000000000..930139b556
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/630-phy_packets.patch
@@ -0,0 +1,66 @@
+Index: linux-2.6.23.16/drivers/net/phy/phy_device.c
+===================================================================
+--- linux-2.6.23.16.orig/drivers/net/phy/phy_device.c 2008-04-20 10:16:21.000000000 +0200
++++ linux-2.6.23.16/drivers/net/phy/phy_device.c 2008-04-29 14:20:03.000000000 +0200
+@@ -44,6 +44,18 @@
+ extern int mdio_bus_init(void);
+ extern void mdio_bus_exit(void);
+
++static int generic_receive_skb(struct sk_buff *skb)
++{
++ skb->protocol = eth_type_trans(skb, skb->dev);
++ return netif_receive_skb(skb);
++}
++
++static int generic_rx(struct sk_buff *skb)
++{
++ skb->protocol = eth_type_trans(skb, skb->dev);
++ return netif_rx(skb);
++}
++
+ struct phy_device* phy_device_create(struct mii_bus *bus, int addr, int phy_id)
+ {
+ struct phy_device *dev;
+@@ -67,6 +79,8 @@
+ dev->bus = bus;
+
+ dev->state = PHY_DOWN;
++ dev->netif_receive_skb = &generic_receive_skb;
++ dev->netif_rx = &generic_rx;
+
+ spin_lock_init(&dev->lock);
+
+Index: linux-2.6.23.16/include/linux/phy.h
+===================================================================
+--- linux-2.6.23.16.orig/include/linux/phy.h 2008-04-20 10:16:21.000000000 +0200
++++ linux-2.6.23.16/include/linux/phy.h 2008-04-20 10:17:58.000000000 +0200
+@@ -289,6 +289,17 @@
+ void (*adjust_link)(struct net_device *dev);
+
+ void (*adjust_state)(struct net_device *dev);
++
++ /*
++ * By default these point to the original functions
++ * with the same name. adding them to the phy_device
++ * allows the phy driver to override them for packet
++ * mangling if the ethernet driver supports it
++ * This is required to support some really horrible
++ * switches such as the Marvell 88E6060
++ */
++ int (*netif_receive_skb)(struct sk_buff *skb);
++ int (*netif_rx)(struct sk_buff *skb);
+ };
+ #define to_phy_device(d) container_of(d, struct phy_device, dev)
+
+Index: linux-2.6.23.16/include/linux/netdevice.h
+===================================================================
+--- linux-2.6.23.16.orig/include/linux/netdevice.h 2008-04-20 10:16:21.000000000 +0200
++++ linux-2.6.23.16/include/linux/netdevice.h 2008-04-20 10:17:58.000000000 +0200
+@@ -426,6 +426,7 @@
+ void *ax25_ptr; /* AX.25 specific data */
+ struct wireless_dev *ieee80211_ptr; /* IEEE 802.11 specific data,
+ assign before registering */
++ void *phy_ptr; /* PHY device specific data */
+
+ /*
+ * Cache line mostly used on receive path (including eth_type_trans())
diff --git a/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
new file mode 100644
index 0000000000..1adcf0d411
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
@@ -0,0 +1,54 @@
+Index: linux-2.6.25.1/drivers/net/phy/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Kconfig 2008-05-12 23:44:33.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Kconfig 2008-05-12 23:45:33.000000000 +0200
+@@ -70,6 +70,12 @@
+ ---help---
+ Currently supports the ADM6996F switch
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell switches"
++ select VLAN_8021Q
++ ---help---
++ Currently supports the Marvell 88E6060 switch.
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+Index: linux-2.6.25.1/drivers/net/phy/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/Makefile 2008-05-12 23:44:50.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/Makefile 2008-05-12 23:45:59.000000000 +0200
+@@ -13,6 +13,7 @@
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+Index: linux-2.6.25.1/drivers/net/phy/mdio_bus.c
+===================================================================
+--- linux-2.6.25.1.orig/drivers/net/phy/mdio_bus.c 2008-05-12 23:44:21.000000000 +0200
++++ linux-2.6.25.1/drivers/net/phy/mdio_bus.c 2008-05-12 23:45:33.000000000 +0200
+@@ -35,6 +35,12 @@
+ #include <asm/irq.h>
+ #include <asm/uaccess.h>
+
++static void mdio_dev_release(struct device *dev)
++{
++ /* nothing to do */
++}
++
++
+ /**
+ * mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
+ * @bus: target mii_bus
+@@ -85,6 +91,7 @@
+
+ phydev->dev.parent = bus->dev;
+ phydev->dev.bus = &mdio_bus_type;
++ phydev->dev.release = mdio_dev_release;
+ snprintf(phydev->dev.bus_id, BUS_ID_SIZE, PHY_ID_FMT, bus->id, i);
+
+ phydev->bus = bus;