summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-07 08:44:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-07 08:44:56 +0000
commitd35bad03e31bd861e231c8c68799c62752b56fa8 (patch)
treee4dff5e623cd35ac5d02b823ba3aeb517e490275 /target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch
parenta1bf28950d16ca97897a524dc74ec0e52ef08fff (diff)
downloadmaster-31e0f0ae-d35bad03e31bd861e231c8c68799c62752b56fa8.tar.gz
master-31e0f0ae-d35bad03e31bd861e231c8c68799c62752b56fa8.tar.bz2
master-31e0f0ae-d35bad03e31bd861e231c8c68799c62752b56fa8.zip
update to 2.6.25.19, and refresh patches
SVN-Revision: 13137
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch
index 760d27aeda..a80482842d 100644
--- a/target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/921-gpio_spi_driver.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.25.17/include/linux/spi/spi_gpio.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.17/include/linux/spi/spi_gpio.h 2008-10-18 23:32:31.000000000 +0200
+--- /dev/null
++++ b/include/linux/spi/spi_gpio.h
@@ -0,0 +1,72 @@
+/*
+ * spi_gpio interface to platform code
@@ -75,10 +73,8 @@ Index: linux-2.6.25.17/include/linux/spi/spi_gpio.h
+int spi_gpio_next_id(void);
+
+#endif /* _LINUX_SPI_SPI_GPIO */
-Index: linux-2.6.25.17/drivers/spi/spi_gpio.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.25.17/drivers/spi/spi_gpio.c 2008-10-18 23:31:27.000000000 +0200
+--- /dev/null
++++ b/drivers/spi/spi_gpio.c
@@ -0,0 +1,249 @@
+/*
+ * Bitbanging SPI bus driver using GPIO API
@@ -329,10 +325,8 @@ Index: linux-2.6.25.17/drivers/spi/spi_gpio.c
+MODULE_AUTHOR("Piot Skamruk <piotr.skamruk at gmail.com>");
+MODULE_DESCRIPTION("Platform independent GPIO bitbanging SPI driver");
+MODULE_LICENSE("GPL v2");
-Index: linux-2.6.25.17/drivers/spi/Kconfig
-===================================================================
---- linux-2.6.25.17.orig/drivers/spi/Kconfig 2008-10-18 23:30:41.000000000 +0200
-+++ linux-2.6.25.17/drivers/spi/Kconfig 2008-10-18 23:30:43.000000000 +0200
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
@@ -100,6 +100,19 @@ config SPI_BUTTERFLY
inexpensive battery powered microcontroller evaluation board.
This same cable can be used to flash new firmware.
@@ -353,10 +347,8 @@ Index: linux-2.6.25.17/drivers/spi/Kconfig
config SPI_IMX
tristate "Freescale iMX SPI controller"
depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
-Index: linux-2.6.25.17/drivers/spi/Makefile
-===================================================================
---- linux-2.6.25.17.orig/drivers/spi/Makefile 2008-10-18 23:30:41.000000000 +0200
-+++ linux-2.6.25.17/drivers/spi/Makefile 2008-10-18 23:30:43.000000000 +0200
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o