summaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
commitf664b7cb17d20e7a32e9bd07e85c9bb7ecb9e2ce (patch)
treeeee31435ae91d4838abf2a566762712522a30f1f /target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
parent83072a149a7d7e6faf7276db7a5f6440d7fa0d24 (diff)
downloadmaster-31e0f0ae-f664b7cb17d20e7a32e9bd07e85c9bb7ecb9e2ce.tar.gz
master-31e0f0ae-f664b7cb17d20e7a32e9bd07e85c9bb7ecb9e2ce.tar.bz2
master-31e0f0ae-f664b7cb17d20e7a32e9bd07e85c9bb7ecb9e2ce.zip
refresh generic 2.6.25 patches to match upstream style
SVN-Revision: 11296
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch24
1 files changed, 9 insertions, 15 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
index 62c64baef3..85b8cb4f91 100644
--- a/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/640-mvswitch.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/drivers/net/phy/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/Kconfig
-+++ linux-2.6.25.4/drivers/net/phy/Kconfig
-@@ -70,6 +70,12 @@ config ADM6996_PHY
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -70,6 +70,12 @@
---help---
Currently supports the ADM6996F switch
@@ -15,11 +13,9 @@ Index: linux-2.6.25.4/drivers/net/phy/Kconfig
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
-Index: linux-2.6.25.4/drivers/net/phy/Makefile
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/Makefile
-+++ linux-2.6.25.4/drivers/net/phy/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,6 +13,7 @@
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
@@ -27,10 +23,8 @@ Index: linux-2.6.25.4/drivers/net/phy/Makefile
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
-Index: linux-2.6.25.4/drivers/net/phy/mdio_bus.c
-===================================================================
---- linux-2.6.25.4.orig/drivers/net/phy/mdio_bus.c
-+++ linux-2.6.25.4/drivers/net/phy/mdio_bus.c
+--- a/drivers/net/phy/mdio_bus.c
++++ b/drivers/net/phy/mdio_bus.c
@@ -35,6 +35,12 @@
#include <asm/irq.h>
#include <asm/uaccess.h>
@@ -44,7 +38,7 @@ Index: linux-2.6.25.4/drivers/net/phy/mdio_bus.c
/**
* mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
* @bus: target mii_bus
-@@ -85,6 +91,7 @@ int mdiobus_register(struct mii_bus *bus
+@@ -85,6 +91,7 @@
phydev->dev.parent = bus->dev;
phydev->dev.bus = &mdio_bus_type;